Medium severityOSV Advisory· Published Jun 9, 2025· Updated Jun 17, 2026
CVE-2025-49130
CVE-2025-49130
Description
Laravel Translation Manager is a package to manage Laravel translation files. Prior to version 0.6.8, the application is vulnerable to Cross-Site Scripting (XSS) attacks due to incorrect input validation and sanitization of user-input data. An attacker can inject arbitrary HTML code, including JavaScript scripts, into the page processed by the user's browser, allowing them to steal sensitive data, hijack user sessions, or conduct other malicious activities. Only authenticated users with access to the translation manager are impacted. The issue is fixed in version 0.6.8.
AI Insight
LLM-synthesized narrative grounded in this CVE's description and references.
Affected packages
Versions sourced from the GitHub Security Advisory.
| Package | Affected versions | Patched versions |
|---|---|---|
barryvdh/laravel-translation-managerPackagist | < 0.6.8 | 0.6.8 |
Affected products
2- Range: v0.1.0, v0.1.1, v0.1.2, …
Patches
Vulnerability mechanics
References
6- github.com/advisories/GHSA-j226-63j7-qrqhghsaADVISORY
- nvd.nist.gov/vuln/detail/CVE-2025-49130ghsaADVISORY
- github.com/barryvdh/laravel-translation-manager/commit/527446ed419f90f2319675fc5211cb8f851d7a1fnvdWEB
- github.com/barryvdh/laravel-translation-manager/pull/475nvdWEB
- github.com/barryvdh/laravel-translation-manager/releases/tag/v0.6.8nvdWEB
- github.com/barryvdh/laravel-translation-manager/security/advisories/GHSA-j226-63j7-qrqhnvdWEB
News mentions
0No linked articles in our index yet.