VYPR
Vypr IntelligenceAI-generatedOct 23, 2026· 6 CVEs

AWS: Six Vulnerabilities Disclosed, Including Critical SageMaker and CICD Flaws

A batch of six vulnerabilities, including critical flaws in SageMaker and CICD toolchain, were disclosed across AWS services from October 20-23, 2026.

Key findings

  • Six AWS vulnerabilities disclosed between Oct 20-23, 2026, ranging from Medium to High severity.
  • Critical flaws include privilege escalation in CICD toolchain (CVE-2026-112407) and code execution in SageMaker SDK (CVE-2026-112408).
  • Vulnerabilities affect multiple AWS services including Athena, SAM CLI, and aws-c-mqtt.
  • Remediation involves updating specific service versions, with some fixes applied server-side by AWS.
  • Users should review IAM policies and update affected components to mitigate risks.

On October 20-23, 2026, a batch of six vulnerabilities was disclosed across various AWS services, with severities ranging from Medium to High. The disclosures highlight issues in code validation, memory allocation, OS command injection, authorization checks, and privilege assignment, impacting services like AWS MCP Server, aws-c-mqtt, AWS SAM CLI, Amazon Athena, Amazon SageMaker, and AWS CICD-toolchain-for-serverless-applications.

One of the most critical vulnerabilities, CVE-2026-112407 (CVSSv3 8.8), found in AWS CICD-toolchain-for-serverless-applications versions 1.0.7 through 1.0.10, involves incorrect privilege assignment in the IAM policy. This flaw could allow authenticated users with push access to the source repository to escalate privileges and access or modify resources outside the intended application stack within the same AWS account.

Another high-severity vulnerability, CVE-2026-112408 (CVSSv3 8.1), affects the Amazon SageMaker Python SDK. Versions V3 before 3.10.0 and V2 before 2.257.3 suffer from a missing verification of the communication channel's source in the default_bucket() function. This could enable remote actors to achieve code execution within the target SageMaker environment and potentially obtain IAM credentials by pre-creating a predictably named bucket.

CVE-2026-115414, a high-severity (CVSSv3 7.8) OS command injection vulnerability, was identified in the Terraform hook of AWS SAM CLI versions prior to 1.166.2. An attacker influencing the Terraform configuration or plan file could execute arbitrary commands as the build user on the host system.

Additionally, CVE-2026-115416 (CVSSv3 7.7) presents an incorrect authorization check in Amazon Athena engine version 3. This could permit an authenticated user to read AWS account identifiers and SQL statement text query metadata from other AWS accounts, though direct access to query results or S3 data was not compromised.

A denial-of-service vulnerability, CVE-2026-115417 (CVSSv3 7.5), was found in the MQTT 3.1.1 compatibility adapter in AWS aws-c-mqtt before version 0.16.2. A remote actor could exploit this memory allocation issue to cause a denial of service for the client application.

Finally, CVE-2026-115845, a medium-severity (CVSSv3 6.4) vulnerability, was present in the run_script tool's Python code validator within AWS MCP Server. An authenticated remote user could execute arbitrary code within their isolated session via a crafted script due to an incomplete list of disallowed inputs. AWS has addressed this issue service-side, requiring no customer action.

For CVE-2026-115417, users are advised to upgrade to aws-c-mqtt 0.16.2 or later. For CVE-2026-115414, remediation involves updating AWS SAM CLI to version 1.166.2 or later. Amazon SageMaker Python SDK users should update to V3 3.10.0 or V2 2.257.3 or later. AWS has fixed CVE-2026-115845 service-side. Specific remediation details for CVE-2026-112407 and CVE-2026-115416 are not detailed in the provided information but generally involve updating to patched versions or reviewing IAM policies.

This batch of vulnerabilities underscores the importance of continuous security vigilance across AWS services. Users should prioritize updating affected components and reviewing their IAM policies and configurations to mitigate risks associated with privilege escalation, code execution, and denial-of-service attacks. Staying informed about security advisories and applying patches promptly remains crucial for maintaining a secure cloud environment.

AI-written article. Grounded in 6 CVE records listed below.